Uploaded image for project: 'Gradle'
  1. Gradle
  2. GRADLE-3338

Fetching artifacts from s3 backed repository fails with jdk8u60

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: 2.4, 2.5, 2.6, 2.7-rc-1, 2.7
    • Fix Version/s: 2.7-rc-2

      Description

      https://discuss.gradle.org/t/fetching-artifacts-from-s3-backed-repository-fails-with-jdk8u60/11298

      After updating oracle jdk to version 8u60, I met a following error below.

      AWS authentication requires a valid Date or x-amz-date header (Service: Amazon S3; Status Code: 403; Error Code: AccessDenied; Request ID: D5BEFCA132123ECE)
      As a result of investigating the problem, I guess that this problem is same as an issue and due to version of joda-time.
      The report says we can use joda-time 2.8.1 with jdk 8u60, but I found Gradle uses an old version 2.7 of joda-time as a source, and Gradle doesn't use a latest vesion of aws-java-sdk which AWS released.

      As workarround, I downgraded jdk I'm using. However, I would like gradle to support latest jdk8.

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            adrianbk Adrian Kelly (Inactive)
            Reporter:
            big-guy Sterling Greene
          • Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development