Uploaded image for project: 'Gradle'
  1. Gradle
  2. GRADLE-3307

Gradle produces java.io.NotSerializableException for dependency resolve errors using the Tooling API

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.2-rc-1

      Description

      https://discuss.gradle.org/t/gradle-produces-java-io-notserializableexception-for-dependency-resolve-errors-using-the-tooling-api/10037

      If I have a dependency in build.gradle that doesn't resolve the error produced via running the 'grails' command is which uses the Gradle Tooling API:

      java.io.NotSerializableException: org.gradle.api.internal.artifacts.DefaultModuleVersionSelector
      at org.gradle.tooling.internal.provider.PayloadSerializer.serialize(PayloadSerializer.java:82)

        Attachments

          Activity

            People

            Assignee:
            lhotari Lari Hotari
            Reporter:
            big-guy Sterling Greene
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: