Uploaded image for project: 'Gradle'
  1. Gradle
  2. GRADLE-2917

jacoco plugin may cause "can't change resolved configuration"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.10-rc-1

      Description

      Jacoco plugin may cause following exception during configuration time: "You can't change a configuration which is not in unresolved state!"

      Full stack trace:

      https://gist.github.com/szczepiq/7ff21c2d6eaffbb90463/raw/9cbb389c58b8505474792aaee00210ed9f5ee03f/gistfile1.txt

      In the code, I see that evaluation of the conventionMapping adds the dependency. I suggest we change that to use beforeResolve hook.

        Attachments

          Activity

            People

            Assignee:
            szczepiq Szczepan Faber
            Reporter:
            szczepiq Szczepan Faber
            Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: