Uploaded image for project: 'Gradle'
  1. Gradle
  2. GRADLE-2831

Gradle's ant dependency needs to be updated to work with Java 8. Ant will report "Invalid Constant Pool entry Type 18" at some times

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.8-rc-1

      Description

      Hi guys,

      We are using Gradle 1.4 and running into this issue: [1]https://issues.apache.org/bugzilla/sh.... This was fixed in Ant 1.9.0 ([2]https://svn.apache.org/repos/asf/ant/...). The current ant version is 1.9.1. Before shipping 1.7, can you update the version of ant in use? Because we're using Gradle on 1.8 projects, we're running into this issue (and because we also use the "depend" feature). If this goes into 1.7 we will upgrade our build systems to use 1.7.

      Thanks
      Richard
      ----------------------------------------------------------------------------------------
      [1] https://issues.apache.org/bugzilla/show_bug.cgi?id=54090
      [2] https://svn.apache.org/repos/asf/ant/core/trunk/WHATSNEW

        Attachments

          Activity

            People

            Assignee:
            breskeby René Gröschke
            Reporter:
            forums Gradle Forums
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: