Uploaded image for project: 'Gradle'
  1. Gradle
  2. GRADLE-2765

Support disabling of XML test report

    Details

    • Type: Improvement
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: 1.6-rc-1
    • Fix Version/s: 1.7-rc-1

      Description

      Some custom JUnit runners have their own reporting, and Gradle's XML/HTML reports aren't required. It's already possible to disable the HTML report, but it should also be possible to disable the XML report. This might also allow to work around issues with Cucumber, JBehave, and similar tools that report "deeper" test hierarchies to JUnit which our reporting can't handle. See: http://forums.gradle.org/gradle/topics/npe_in_simplemarkupwriter_when_generating_report_for_thucydides_jbehave_junit_tests

        Activity

        ae6rt mark petrovic added a comment -

        If we had a way of disabling XML reports, I could migrate from gradle 1.3 to gradle latest. My cucumber-jvm tests won't run with anything more recent than gradle 1.3.

        thanks.

        stolsvik Endre Stølsvik added a comment - - edited

        Inside the Test-task: reports.junitXml.enabled = false
        .. and possibly for good measure: reports.html.enabled = false

        ae6rt mark petrovic added a comment -

        Thanks for this bug fix.

        Now I'm blocked on http://issues.gradle.org/browse/GRADLE-2739 because my Cucumber scenario descriptions have "/" in them.

        FAILURE: Build failed with an exception.

        • What went wrong:
          Execution failed for task ':regression:mapi:intTest'.
          > Failed to notify test output listener.
          > Problems writing to file: /Users/petrovic/Projects/xoom/qa/prod/regression/mapi/build/test-results/binary/intTest/Scenario: FX cache clearing for /fx endpoint.stdout.bin

        In my test task I have

        reports.junitXml.enabled = false
        reports.html.enabled = false

        I'm not sure this build failure should or should not have been reached given the disabling of the reports. When reports are disabled, should Gradle be attempting to write any reports anywhere?

        ae6rt mark petrovic added a comment -

        I submitted a pull request to help fix escaping literal "/" in Cucumber Scenario and step def "test names": https://github.com/gradle/gradle/pull/190


          People

          • Assignee:
            Unassigned
            Reporter:
            pniederw Peter Niederwieser
          • Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development