Uploaded image for project: 'Gradle'
  1. Gradle
  2. GRADLE-1060

Reconsider taskGroup naming

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: 0.9
    • Fix Version/s: 0.9-rc-1

      Description

      The new taskGroup feature works nicely, but its naming may need reconsideration:

      task myTask {
          description = "Does something interesting."
          taskGroup = "Interesting"
      }
      

      There is an asymmetry here. It should ideally be either taskDescription and taskGroup or description and group. group is a bit unfortunate as it's meaning may be confused with the project's group property.

        Attachments

          Activity

            People

            Assignee:
            adammurdoch Adam Murdoch
            Reporter:
            cbeams Chris Beams
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: