Gradle
  1. Gradle
  2. GRADLE-1479

OS-X OpenJDK7 Issue with libjnidispatch.dylib

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Resolution: Fixed
    • Affects Version/s: 1.0-milestone-2
    • Fix Version/s: 1.0-milestone-4

      Description

      Something changed between Milestone 1 and Milestone 2 to cause this:

      Sanctum-Sanctorium:bin robert$ gradle -version

      FAILURE: Build failed with an exception.

      • What went wrong:
        Could not locate JNA native lib resource '/com/sun/jna/darwin-universal/libjnidispatch.dylib'.
      • Try:
        Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

      Milestone 1 works just fine. Now, that's almost certainly an OS-X OpenJDK 7 issue, so I marked it as "trivial", but I wanted to make people aware.

        Activity

        Shawn Ma
        added a comment -

        Doesn't work on solaris x86 as well:
        FAILURE: Build failed with an exception.

        • What went wrong:
          Could not locate JNA native lib resource '/com/sun/jna/sunos-i386/libjnidispatch.so'.
        • Try:
          Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
        Show
        Shawn Ma
        added a comment - Doesn't work on solaris x86 as well: FAILURE: Build failed with an exception. What went wrong: Could not locate JNA native lib resource '/com/sun/jna/sunos-i386/libjnidispatch.so'. Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
        Jochen Hinrichsen
        added a comment -

        I just built HEAD, same problem on AIX 6.1, IBM Java 1.6.0:

        $ /applications/CDS/gradle-1.0-milestone-4-20110721150841+0200/bin/gradle -v

        FAILURE: Build failed with an exception.

        • What went wrong:
          Could not locate JNA native lib resource '/com/sun/jna/aix-ppc64/libjnidispatch.a'.
        • Try:
          Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
        Show
        Jochen Hinrichsen
        added a comment - I just built HEAD, same problem on AIX 6.1, IBM Java 1.6.0: $ /applications/CDS/gradle-1.0-milestone-4-20110721150841+0200/bin/gradle -v FAILURE: Build failed with an exception. What went wrong: Could not locate JNA native lib resource '/com/sun/jna/aix-ppc64/libjnidispatch.a'. Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
        Jochen Hinrichsen
        added a comment -

        Workaround for esoteric OS/ arch combinations

        Show
        Jochen Hinrichsen
        added a comment - Workaround for esoteric OS/ arch combinations
        Jochen Hinrichsen
        added a comment -

        Retried on milestone-5-20110908101939, still same problem.

        Show
        Jochen Hinrichsen
        added a comment - Retried on milestone-5-20110908101939, still same problem.
        Peter Niederwieser
        added a comment -

        A stack trace would help. Regardless, I'm fairly certain that the problem is fixed on master, because we now have a CI build that simulates a JNA-less OS. Not sure if it's fixed in m5 though (we have done some work on this since m5).

        Show
        Peter Niederwieser
        added a comment - A stack trace would help. Regardless, I'm fairly certain that the problem is fixed on master, because we now have a CI build that simulates a JNA-less OS. Not sure if it's fixed in m5 though (we have done some work on this since m5).

          People

          • Assignee:
            Adam Murdoch
            Reporter:
            Robert Fischer
          • Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: