[GRADLEREV-16] Review name of `TestReports` interface Created: 24/Jul/13  Updated: 26/Jul/13  Resolved: 26/Jul/13

Status: Resolved
Project: Gradle Code Review Tasks
Component/s: None
Affects Version/s: None
Fix Version/s: None

Type: Task Priority: Major
Reporter: Adam Murdoch Assignee: Luke Daley
Resolution: Fixed Votes: 0
Labels: None


I wonder if we should give this a different name. We're going to need a ReportContainer subtype for the `TestReport` task type to implement that defines just the HTML report and not the XML report. This will mean the name `TestReports` will be a bit ambiguous.

We also want to eventually get rid of any reporting from the `Test` task type, so that it only produces test results, so we probably want to reserve the name `TestReports` for the `TestReport` task type to implement.

Comment by Adam Murdoch [ 24/Jul/13 ]

Needs to happen before 1.7 is released (the interface is not @Incubating).

Generated at Wed Jun 30 11:18:19 CDT 2021 using Jira 8.4.2#804003-sha1:d21414fc212e3af190e92c2d2ac41299b89402cf.