[GRADLE-951] The wording around forkEvery Created: 01/Jun/10 Updated: 04/Jan/13 Resolved: 24/Mar/11
|Reporter:||Szczepan Faber||Assignee:||Szczepan Faber|
User guide mentions: "You can modify this behavior by setting forking to false or set the forkmode to once." However, the way you do it in practice: "forkEvery = null". Also, the latter does not look good in the gradle script, e.g. one cannot figure out what does forkEvery = null mean without looking at the docs. If I may I'd humbly vote for: forkMode = ONCE
|Comment by Adam Murdoch [ 02/Jun/10 ]|
This part of the user guide has been updated for 0.9-preview-2. The default is actually forkEvery = null, so you don't really need to put this in your build file.
The problem with the name forkMode is that it doesn't read particularly well with an integer value, eg forkMode = 15. And forkMode = ONCE isn't particularly self-describing, I think. Perhaps we want a forkOnce() method which simply sets forkEvery = null.
|Comment by Szczepan Faber [ 02/Jun/10 ]|
>The default is actually forkEvery = null, so you don't really need to put this in your build file.
Very cool, thanks! I think this default value is much better.
forkOnce() method - up to you guys. I'm happy because I can stick with the default. Two methods changing the same property may lead to weird behavior when someone uses both...
|Comment by Szczepan Faber [ 24/Mar/11 ]|
The default for forkEvery is 0 at this moment. It does not make sense to create an extra forkOnce() method in the api at this time.