[GRADLE-410] doFirst and doLast tasks should be allowed to have names -- otherwise, it's hard to 'skip' them Created: 19/Feb/09  Updated: 04/Jan/13  Resolved: 31/Aug/09

Status: Resolved
Project: Gradle
Affects Version/s: None
Fix Version/s: None

Type: Bug
Reporter: Jon Cox Assignee: Hans Dockter
Resolution: Won't Fix Votes: 0


While doFirst and doLast tasks can be extremely handy,
the fact that they're anonymous means there's no easy way
to skip them. For that reason, I think they should take a name.

Comment by Jon Cox [ 19/Feb/09 ]

See also: GRADLE-411 which argues for subsuming this functionality
by adding a few more optional args to createTask(...).

Comment by Hans Dockter [ 31/Aug/09 ]

I think this is issue is partly based on the misunderstanding mentioned in GRADLE-411. One could still argue that actions should have an id. But we haven't come across a good use case for this. Therefore I'm closing this issue. If we have a use case we can always reopen it.

Generated at Wed Jun 30 11:29:24 CDT 2021 using Jira 8.4.2#804003-sha1:d21414fc212e3af190e92c2d2ac41299b89402cf.