[GRADLE-1415] 'eclipse' plugin with 'war' plugin fails with class cast exception Created: 03/Mar/11  Updated: 04/Jan/13  Resolved: 26/Apr/11

Status: Resolved
Project: Gradle
Affects Version/s: 1.0-milestone-1
Fix Version/s: 1.0-milestone-4

Type: Bug
Reporter: Stephane Gall├Ęs Assignee: Peter Niederwieser
Resolution: Fixed Votes: 1


 Description   

To reproduce the problem, create the following build :

apply plugin: 'war'
apply plugin: 'eclipse'
dependencies {
      compile  fileTree(dir: 'libs', includes: ['*.jar'])      
}

and add at least one jar in the libs directory, then launch the 'eclipse' task. You get :

 
Execution failed for task ':eclipseWtpComponent'.
Cause: Cannot cast object '[C:\Temp\testgradle\libs\toto.jar]' with class 'java.util.ArrayList' 
to class 'java.util.LinkedHashSet' due to: groovy.lang.GroovyRuntimeException: Could not find 
matching constructor for: java.util.LinkedHashSet(java.io.File)

It's a regression as it can not be reproduced with Gradle 0.9.2


Generated at Wed Jun 30 11:54:58 CDT 2021 using Jira 8.4.2#804003-sha1:d21414fc212e3af190e92c2d2ac41299b89402cf.