Details

    • Type: New Feature New Feature
    • Status: Resolved Resolved
    • Resolution: Fixed
    • Affects Version/s: 0.6
    • Fix Version/s: 0.9-rc-1

      Description

      Create an announce task that will be used as a framework to allow various implementations for conveying announcements to things such as twitter, email, growl (on a mac). See the thread on the mailing list referencing this idea (http://www.nabble.com/Announce-plugin-or-task--td23681789.html)

        Issue Links

          Activity

          Hamlet D'Arcy
          added a comment -

          a group of us have committed to getting together and fixing this issue. Is it valuable to fix this issue alone, or does 494 really need to be part of a proper fix?

          Show
          Hamlet D'Arcy
          added a comment - a group of us have committed to getting together and fixing this issue. Is it valuable to fix this issue alone, or does 494 really need to be part of a proper fix?
          Hans Dockter
          added a comment -

          494 does not need to be part of the fix. I have changed the link type. As I understand 494, it would be part of the Gradle Gradle build itself.

          Show
          Hans Dockter
          added a comment - 494 does not need to be part of the fix. I have changed the link type. As I understand 494, it would be part of the Gradle Gradle build itself.
          Hamlet D'Arcy
          added a comment -

          Hi Gang, this work is complete, as is the general purpose Announce plugin. Twitter, Snarl, and Ubuntu notifications all work. The userguide was updated as well. We might work just a little bit more on the user guide to make it nicer. The pull request was sent from github: http://github.com/madmarkus/gradle
          Contact hamletdrc@gmail.com if you need any changes or questions answered.

          Growl is not yet supported because we do not have a Mac.

          Show
          Hamlet D'Arcy
          added a comment - Hi Gang, this work is complete, as is the general purpose Announce plugin. Twitter, Snarl, and Ubuntu notifications all work. The userguide was updated as well. We might work just a little bit more on the user guide to make it nicer. The pull request was sent from github: http://github.com/madmarkus/gradle Contact hamletdrc@gmail.com if you need any changes or questions answered. Growl is not yet supported because we do not have a Mac.
          Hamlet D'Arcy
          added a comment -

          Is there anything we can do to make the patch merge easier?

          Show
          Hamlet D'Arcy
          added a comment - Is there anything we can do to make the patch merge easier?
          Hans Dockter
          added a comment -

          Hi Hamlet,

          one thing we have been discussing is a more general issue. What are the Gradle core plugins and what not. There are three categories of plugins

          1. Core (e.g. Java)
          2. Maintained by Gradle (e.g. Jetty)
          3. External

          The announce plugins falls into the second category. The problem is that Gradle is not modularized yet. So at the moment we are just monolithic and don't distinguish between 1 and 2. Therefore we decided yesterday to merge the announce plugin into the core distribution for 0.9. In 1.0 we will modularize.

          The other thing we have been discussing is extracting a messaging layer which would go into the gradle-core.jar. But we won't do this for 0.9 I think. So because of those discussions the merge got delayed. But we will merge it soon.

          Thanks again for all your work

          Show
          Hans Dockter
          added a comment - Hi Hamlet, one thing we have been discussing is a more general issue. What are the Gradle core plugins and what not. There are three categories of plugins Core (e.g. Java) Maintained by Gradle (e.g. Jetty) External The announce plugins falls into the second category. The problem is that Gradle is not modularized yet. So at the moment we are just monolithic and don't distinguish between 1 and 2. Therefore we decided yesterday to merge the announce plugin into the core distribution for 0.9. In 1.0 we will modularize. The other thing we have been discussing is extracting a messaging layer which would go into the gradle-core.jar. But we won't do this for 0.9 I think. So because of those discussions the merge got delayed. But we will merge it soon. Thanks again for all your work
          Adam Murdoch
          added a comment -

          I have reviewed the code, it looks good to me. I will merge it soon.

          Show
          Adam Murdoch
          added a comment - I have reviewed the code, it looks good to me. I will merge it soon.
          Hamlet D'Arcy
          added a comment -

          @Hans

          IMO, plugins need to be easy to load and easy to find. Having to load plugins from all across of the Internet from URLs and such is a pain. I like what Griffon and Grails have done, where there is one plugin repository and many people can contribute to that central repo. Until this type of system exists, then I would keep putting the plugins into Gradle Core. I think we agree

          Show
          Hamlet D'Arcy
          added a comment - @Hans IMO, plugins need to be easy to load and easy to find. Having to load plugins from all across of the Internet from URLs and such is a pain. I like what Griffon and Grails have done, where there is one plugin repository and many people can contribute to that central repo. Until this type of system exists, then I would keep putting the plugins into Gradle Core. I think we agree
          Hans Dockter
          added a comment -

          @Hamlet I have merged the Announce plugin into a local branch. Everything is ready for committing it except that the SnarlTest is failing on my Ubuntu machine. Any ideas?

          Show
          Hans Dockter
          added a comment - @Hamlet I have merged the Announce plugin into a local branch. Everything is ready for committing it except that the SnarlTest is failing on my Ubuntu machine. Any ideas?
          Jason Porter
          added a comment -

          @Hans: Snarl is a Windows version of Mac's Growl, it won't work on Ubuntu.

          Show
          Jason Porter
          added a comment - @Hans: Snarl is a Windows version of Mac's Growl, it won't work on Ubuntu.

            People

            • Assignee:
              Hans Dockter
              Reporter:
              Jason Porter
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: