Gradle
  1. Gradle
  2. GRADLE-2326

Using suites with TestNGOptions causes Stacktrace

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: 1.0-rc-3
    • Fix Version/s: 1.2-rc-1

      Description

      I'm running my TestNG tests off of Gradle and I've been trying to use the xml suite properties to use my xml with Gradle. However every time I try to run the suite API Gradle fails and gives me a stacktrace saying Method Missing

      test{
      useTestNG()
      //other properties
      options

      { suites(file('headless.xml')) }

      }

      The stack cause:

      Caused by: java.lang.StackOverflowError
      at org.gradle.api.tasks.testing.testng.TestNGOptions.methodMissing(TestNGOptions.groovy:204)

        Issue Links

          Activity

          Greg added a comment -

          Mark invalid: I moved the suite API outside of the brackets and did options.suites(file('<my suite>')) and its working


            People

            • Assignee:
              Unassigned
              Reporter:
              Greg
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development