Gradle
  1. Gradle
  2. GRADLE-2114

Tooling API should provide information about whether dependencies should be exported

    Details

    • Type: Improvement Improvement
    • Status: Open Open
    • Resolution: Unresolved
    • Affects Version/s: 1.0-milestone-7, 1.0-milestone-8
    • Fix Version/s: None

      Description

      Currently, STS, lacking information from the tooling API whether a dependency is to be exported or not is exporting all dependencies.

      Some users however feel strongly that this is a very bad solution. For an example see here:
      http://forum.springsource.org/showthread.php?123333-Gradle-import-produces-wrong-classpath-files&p=402394#post402394

        Activity

        Hide
        Kris De Volder
        added a comment -
        Show
        Kris De Volder
        added a comment - This issue is blocking https://issuetracker.springsource.com/browse/STS-2460

          People

          • Assignee:
            Unassigned
            Reporter:
            Kris De Volder
          • Votes:
            3 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated: