Gradle
  1. Gradle
  2. GRADLE-1532

Gradle throwing error when trying to execute parallel functional test with Selenium Grid and testNG

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0-milestone-4

      Description

      I am using TestNG with Gradle to run functional tests in parallel with
      Selenium Grid. I was getting this error while trying to execute two
      test classes in parallel.

      Failed to dispatch message
      org.gradle.messaging.dispatch.MethodInvocation@1c71474e.
      org.gradle.messaging.dispatch.DispatchException: Failed to dispatch
      message org.gradle.messaging.dispatch.MethodInvocation@1c71474e.
      at org.gradle.messaging.dispatch.ExceptionTrackingDispatch.dispatch(ExceptionTrackingDispatch.java:34)
      at org.gradle.messaging.dispatch.AsyncDispatch.dispatchMessages(AsyncDispatch.java:129)
      at org.gradle.messaging.dispatch.AsyncDispatch.access$000(AsyncDispatch.java:33)
      at org.gradle.messaging.dispatch.AsyncDispatch$1.run(AsyncDispatch.java:69)
      at org.gradle.messaging.concurrent.DefaultExecutorFactory$StoppableExecutorImpl$1.run(DefaultExecutorFactory.java:63)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:680)
      Caused by: java.lang.IllegalArgumentException: Received a completed
      event for test with unknown id '1.8'.
      at org.gradle.api.internal.tasks.testing.results.StateTrackingTestResultProcessor.completed(StateTrackingTestResultProcessor.java:48)
      at org.gradle.api.internal.tasks.testing.results.AttachParentTestResultProcessor.completed(AttachParentTestResultProcessor.java:51)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:35)
      at org.gradle.messaging.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:24)
      at org.gradle.messaging.dispatch.ExceptionTrackingDispatch.dispatch(ExceptionTrackingDispatch.java:32)
      ... 7 more

      Initially I didn't know what was going on. Later I noticed two methods
      in each class had same name. When I changed the name of one of the
      methods(that had same name as in other class) in one class, the tests
      ran in parallel without any error.

      It has to be problem with either Gradle or TestNG. It should be able to handle same method names in two different classes.

        Activity

        Szczepan Faber
        added a comment -

        very tiny project that reproduces the problem

        Show
        Szczepan Faber
        added a comment - very tiny project that reproduces the problem
        Szczepan Faber
        made changes -
        Field Original Value New Value
        Attachment sample.zip [ 10214 ]
        Szczepan Faber <szczepiq@gmail.com> committed 96539748ac6965c5cea7b0a11d6d7064ad7fde4f (3 files)
        Reviews: none

        GRADLE-1532 Fixed the issue with TestNG parallel tests. The problem was caused because method name was used to identify the test id. When someone used TestNG's feature @Test(invocationCount = 2, threadPoolSize = 2) then just the method name was not enough for identification. My fix is using the ITestResult from TestNG as an identifier for internal use in a hashmap. Also I did very simple refactoring that should help in debugging similar issues in future.

        Szczepan Faber
        added a comment -

        Fixed in master

        Show
        Szczepan Faber
        added a comment - Fixed in master
        Szczepan Faber
        made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 1.0-milestone-4 [ 10060 ]
        Resolution Fixed [ 1 ]
        Daz DeBoer
        made changes -
        Workflow jira [ 12954 ] jira with pivotal tracker [ 14369 ]
        Luke Daley
        made changes -
        Workflow jira with pivotal tracker [ 14369 ] jira with pivotal tracker (no resolved, only closed) [ 16286 ]
        Status Resolved [ 5 ] Closed [ 6 ]
        Luke Daley
        made changes -
        Workflow jira with pivotal tracker (no resolved, only closed) [ 16286 ] Copy of jira with pivotal tracker (no closed, only resolved) [ 18959 ]
        Status Closed [ 6 ] Resolved [ 5 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Asmita Vaidya
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: