Gradle
  1. Gradle
  2. GRADLE-1188

Gradle daemon caches current working directory

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.9-rc-3

      Description

      repro:

      1. kill any running daemon
      2. cd <multi-project-root-dir>
      3. ./gradlew build
      4. Notice everything works as expected, all subprojects build
      5. cd <multi-project-root-dir>/<subproject1-dir>
      6. ../gradlew build
      7. Notice that all projects build. This is unexpected; only the leaf node project should build.

      This unexpected behavior is appears to be due to the Gradle daemon caching CWD the first time it's run. This amounts to an unusable experience, even within the same multi-project build.

      For now, we're running with --no-daemon to avoid this.

      It is also a problem when working across projects. Starting the daemon in project1 means that any gradle invocations from project2 will inadvertently trigger builds in project1 – not exactly what's expected.

        Activity

        Adam Murdoch added a comment -

        This is fixed in master branch.


          People

          • Assignee:
            Hans Dockter
            Reporter:
            Chris Beams
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development