Gradle
  1. Gradle
  2. GRADLE-1176

IdeaPlugin does not seem to honor set project.name as the User Guide suggests

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.0-milestone-4

      Description

      The User Guide, in table 28.2, 28.3 and 28.4 implies that the generated IntelliJ meta files will be named based on projectDir/<project.name>. However, I tried altering a project's name in settings.gradle and that name was not used by the IdeaPlugin.

      The problem is that i have a multi-project structure where the root directory is named hibernate-core and a sub-project is in a directory hibernate-core/hibernate-core. Trying to create an IntelliJ project for this creates 2 files named hibernate-core.iml. IntelliJ takes the name of the module based on the name of the iml file (it would seem), so it has problems with this.

        Activity

        Steve Ebersole created issue -
        Adam Murdoch made changes -
        Field Original Value New Value
        Fix Version/s 0.9.1 [ 16656 ]
        Adam Murdoch made changes -
        Fix Version/s 0.9.1 [ 16656 ]
        Fix Version/s 1.0-milestone-1 [ 17027 ]
        Adam Murdoch made changes -
        Assignee Hans Dockter [ hans_d ]
        Adam Murdoch made changes -
        Fix Version/s 0.9.2 [ 17027 ]
        Fix Version/s 1.0-milestone-1 [ 17084 ]
        Adam Murdoch made changes -
        Fix Version/s 1.0-milestone-2 [ 17051 ]
        Fix Version/s 1.0-milestone-1 [ 17084 ]
        Contegix Support made changes -
        Project Import Sat Mar 19 09:23:24 CDT 2011 [ 1300544604020 ]
        Adam Murdoch made changes -
        Fix Version/s 1.0-milestone-3 [ 10050 ]
        Fix Version/s 1.0-milestone-2 [ 10049 ]
        Adam Murdoch made changes -
        Fix Version/s 1.0-milestone-4 [ 10060 ]
        Fix Version/s 1.0-milestone-3 [ 10050 ]
        Szczepan Faber made changes -
        Assignee Szczepan Faber [ szczepiq ]
        Szczepan Faber added a comment - - edited
        Szczepan Faber made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Daz DeBoer made changes -
        Workflow jira [ 11923 ] jira with pivotal tracker [ 13884 ]
        Adam Murdoch made changes -
        Component/s IDE integration [ 10015 ]
        Component/s Idea [ 10024 ]
        Luke Daley made changes -
        Workflow jira with pivotal tracker [ 13884 ] jira with pivotal tracker (no resolved, only closed) [ 16648 ]
        Status Resolved [ 5 ] Closed [ 6 ]
        Luke Daley made changes -
        Workflow jira with pivotal tracker (no resolved, only closed) [ 16648 ] Copy of jira with pivotal tracker (no closed, only resolved) [ 19394 ]
        Status Closed [ 6 ] Resolved [ 5 ]

          People

          • Assignee:
            Szczepan Faber
            Reporter:
            Steve Ebersole
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development